Symptoms
- Domains on Plesk server display Error 500 and the following error message is output to the logs:
CONFIG_TEXT: PHP Fatal error: Uncaught GuzzleHttp\Ring\Exception\RingException: cURL error 77
- Various actions in Plesk fail, including:
- Issuing or updating Let's Encrypt certificates
- Installing or updating WordPress plugins
- Updating licenses
- Authentication via Google
- Installing new extensions from extension catalog
And one or more of the following messages are displayed:CONFIG_TEXT: Error 500
CONFIG_TEXT: Error: Could not get Mozilla tls config: cURL error 77: (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)
CONFIG_TEXT: Unable to initialize NSS: -8023 (SEC_ERROR_PKCS11_DEVICE_ERROR)
For additional searchability: Could not issue a Let's Encrypt SSL/TLS certificate: Failed to connect to the Let's Encrypt server https://acme-v02.api.letsencrypt.org
Cause
Recent CentOS 7 update of NSS packages.
Resolution
-
Connect to the server via SSH
-
Restart all the PHP services including Plesk:
# systemctl restart plesk-php* && systemctl restart sw-engine
Note: if Litespeed is installed, it is required to restart it as well:
# systemctl restart lscgid
Comments
11 comments
Thanks a million Alexander Davydov for having shared this. You helped me fixed major issues blocking payments from our WordPress woocommerce based ecommerce website. The curl requests were triggering this code 77 error.
And it looks like looots of online merchants have the same issue.
Thanks again Alexander
Fixed the same issue on all our Wordpress sites, can't download or update plugins without cURL! (error 77) It would be nice if Plesk restarted these services automatically.
Always send out notifications and emails to all users for this kind of thing. You don't wait till my business is fucked and I google a solution before you start telling me one update caused a server error. What am I paying for? Improve on your customer relation. This really gave me a sleepless night changing what wasn't broken onmy site to no avail only to google search and I find this page telling me some server updates wasted my night. WTF, this is really annoying!
Unfortunately the error "Request Failed with a Fatal Error: Curl error: [77] ." is not resolved after restarting plesk-php* and sw-engine. Any other suggestions?
Edit: Resolved! Since we are also running Litespeed we had to also restart lscgid
Hi,
Can you confirm please if the "Event Handler" --- "Update Installed" is fired after the system updates are completed, and would be safe to run the above command without issue?
Really thank you, it solved the problem. You could also encounter different PHP CURL problems.
This fixed the problem.. Thank you!
If anyone is getting errors such as 'Unit plesk-php.service' cannot be found, try wrapping the above command in quotes, e.g.:
That fixed the problem.. Thank you!
one some instance where there was some plesk-php versions installed but not running the restart of sw-enging was failing due to &&
This so far blindly fixed them
Hi,
thank you for the infos,
we had to switch on/off ssh for the subscription to mitigate the issue, like explained in the following post.
https://talk.plesk.com/threads/could-not-get-mozilla-tls-config-curl-error-77-cannot-update-plugin-et-al.371956/post-936719
I think the real issue for us was:
https://www.plesk.com/kb/support/on-plesk-for-linux-server-curl-command-in-chrooted-shell-or-in-scheduled-task-fails-curl-77-error-setting-certificate-verify-locations/
Cheers!
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