Applicable to:
- Plesk for Linux
Symptoms
-
The Plesk panel data (including the web server configuration files) has been recently migrated to a new Plesk server
-
The nginx web server fails to start and the following error is shown in the Plesk GUI:
New configuration files for the Apache web server were not created due to the errors in configuration templates: nginx: [emerg] bind() to 203.0.113.2:443 failed (99: Cannot assign requested address) nginx: configuration file /etc/nginx/nginx.conf test failed
-
The IP address 203.0.113.2 has been used during the migration, however it is no longer present on the network interfaces of the Linux server
Cause
The file /etc/nginx/plesk.conf.d/server.conf
still contains the outdated 203.0.113.2 IP address, which is mentioned in the error message.
Resolution
Force the recreation of the nginx configuration file by following these steps:
-
Connect to the server via SSH as the root user
-
Disable nginx by executing the following command:
# /usr/local/psa/admin/sbin/nginxmng --disable
-
Enable nginx once again by executing the following command:
# /usr/local/psa/admin/sbin/nginxmng --enable
After this has been done, the IP address that was causing the issue should not be present within the /etc/nginx/plesk.conf.d/server.conf
file any longer.
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