Articles in this section

Plesk for Windows is not accessible with the 503 error: The Module DLL C:\Windows\Microsoft.NET\Framework64\HttpResetModule.dll failed to load

Plesk for Windows kb: technical

Symptoms

  • Plesk for Windows is not accessible with the following error in the browser

  • PleskControlPanel IIS application pool is in the stopped state.

  • If trying to start the pool and accessing Plesk in a browser, the following error appears in the Event Viewer > Windows Logs > Application:

    CONFIG_TEXT: The Module DLL C:\Windows\Microsoft.NET\Framework64\HttpResetModule.dll failed to load. The data is the error.

Cause

Malicious software. Additional information

In the email at Support-TL RE: Problem of malicious software on Windows Plesk servers it's required to know if Microsoft Defender finds them on scans. Run it on the affected server.

Resolution

  1. Connect to the server via RDP.

  2. Open IIS > server name > Modules and remove both %windir%\Microsoft.Net\Framework\HttpResetModule.dll and %windir%\Microsoft.Net\Framework64\HttpResetModule.dll.

  3. Open IIS > server name > Configuration Editor.

  4. Switch to the section system.webServer/globalModules.

  5. Click on the Edit Configuration button.

  6. Remove modules with the same name from this page and save changes.

  7. Restart IIS:

    C:\> iisreset

  8. Check the server for malicious software using any antivirus program. Consider migrating to a new Plesk server

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.