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Error when removing an IP address without assigned domains in Plesk: The IP address is already used for hosting

Plesk for Windows Plesk for Linux ip address

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • When removing an IP address from Plesk at Tools & Settings > IP Addresses, the operation fails with:

    Error: The IP address 203.0.113.2 is already used for hosting.

  • There are no domains assigned to this IP address.

  • Previously, there was a domain (or domains) assigned to this IP address, but they were switched to Forwarding or No Hosting type at Domains > example.com > Hosting Settings.

  • The command below (for IP address from the error message) returns a domain name:

    # plesk db "SELECT d.name FROM DomainServices ds INNER JOIN IpAddressesCollections ipac ON ds.ipCollectionId = ipac.ipCollectionId INNER JOIN domains d ON d.id = ds.dom_id JOIN IP_Addresses ip on ipac.ipaddressid=ip.id WHERE (ds.type = 'web' OR ds.type = 'mail') and ipac.ipAddressId = (select id from IP_Addresses where ip_address='203.0.113.2 ');"
    +-------------+
    | name        |
    +-------------+
    | example.com |

Cause

The domain with Forwarding or No Hosting type still uses this IP address for mail sending.

Resolution

  1. Log in to Plesk.

  2. Go to Tools & Settings > Mail Server Settings.

  3. Change outgoing mail mode to "Send from domain IP addresses" or "Send from the specified IP addresses".

  4. Apply the changes.

  5. Revert the setting back to previous.

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