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An email sent to Gmail from a Plesk server is bounces: Gmail requires all senders to authenticate with either SPF or DKIM

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • When sending an email from a domain in Plesk, a bounce email is received with:

    CONFIG_TEXT: 550-5.7.26 This message does not pass authentication checks (SPF and
    DKIM both
    550-5.7.26 do not pass).

    CONFIG_TEXT: 550-5.7.26 This mail is unauthenticated, which poses a security risk to the
    550-5.7.26 sender and Gmail users, and has been blocked. The sender must
    550-5.7.26 authenticate with at least one of SPF or DKIM. For this message,
    550-5.7.26 DKIM checks did not pass and SPF check for [example.com]
    550-5.7.26 did not pass with ip: [203.0.13.2]. The sender should visit
    550-5.7.26 https://support.google.com/mail/answer/81126#authentication for
    550 5.7.26 instructions on setting up authentication.

    CONFIG_TEXT: Gmail requires all senders to authenticate with either SPF or DKIM
    Authentication results:
    550-5.7.26  DKIM = did not pass
    550-5.7.26  SPF [example.com] with ip: [203.0.113.2] = did not pass
    550-5.7.26
    550-5.7.26  For instructions on setting up authentication, go to
    550 5.7.26  https://support.google.com/mail/answer/81126#authentication 

  • The DNS zone of the domain is hosted externally, not in Plesk.

Cause

Domain's SPF and DKIM records, added on external DNS server, are missing or invalid.

Resolution

  1. Enable DKIM and SPF for the domain.
  2. Go to Domains > example.com > Hosting & DNS tab > DNS Settings and locate DKIM and SPF records.
  3. Copy these DKIM and SPF records and add them on external DNS server which serves domain's DNS zone.
  4. Verify that only one SPF record and one DKIM record exist on external DNS server.
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Comments

4 comments
Date Votes
  • I added SPF and default DKIM record in DNS but not working

    0
  • I've yet this record, and not work. Have you a solution??

    0
  • MD Rashed Bin Kuddus and William Apa Hello,

    If the SPF and DKIM DNS records were added on the Registrar side (externally hosted DNS Zone) of the domain and the issue persist even after the normal DNS propagation times, please consider creating a Support request for further analysis of each situation. 

    Thanks

    0
  • still the same problem

    0

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