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Plesk utilities do not work on a Windows Server: Access is denied

Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • The Windows built-in Administrator was renamed to a different name and does not exist at Computer Management > Local Users and Groups > Users.

  • When restarting any service via Plesk Services Monitor, the operation fails with the following error message in a popup window:

    PLESK_INFO: Access is denied. (Error code 5) at Unable to connect to pipe \\.\pipe\P_047a9f38-4df5-807f-33791b74c301
        at (Con::ClientOverlappedPipe::create line 503)
        at get shared instance of PleskSrcClient(PleskSrvClient::getInstance line 334)
        at Execute --start-plesk-website(execPleskUtil line 111)

  • When running any command tied to a Plesk utility in the Windows Command Prompt, the following error message appears:

    C:\> plesk version
    Access is denied

Cause

Plesk requires the Windows built-in Administrator to work properly in order to function as expected.

Resolution

Recreate the Windows built-in Administrator user by either renaming it back, creating a new one with all of the required privileges and groups or executing the following steps while logged in as a user with enough privileges:

1. Log into your server via RDP

2. Run Command Prompt as a user with enough privileges

3. Execute the following command:

C:\>net user administrator /active:yes

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