Articles in this section

Unable to choose language in Plesk. Only English is available

Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • One only English language is available in Plesk interface in spite of purchased additional language pack.

  • The following can be found in C:\ParallelsInstaller\autoinstaller3.log

    CONFIG_TEXT: [2020-05-07 21:03:30.276281] Registering locales...
    [2020-05-07 21:03:30.824719] Package action: Execute, package: plesk-l10n, exec time: 0 sec. desc: "program='[PLESK_INSTALLDIR]\admin\engine\php.exe'," "command-line='C:\Program Files (x86)\Plesk\admin\plib\scripts\add-locales.php'," "working-dir=''," "context=''," "arch=''", output='~empty'
    [2020-05-07 21:03:30.824719] C:\Program Files (x86)\Plesk\admin\engine\php.exe "C:\Program Files (x86)\Plesk\admin\plib\scripts\add-locales.php" failed with error 255(0x000000ff). Output:
    Sub-action 'Execute' failed with error code: 255(0x000000ff)

Cause

Installed locales are not properly registered.

Resolution

  1. Connect to the server via RDP

  2. Launch locale installer in command line to register these:

    C:\> plesk php "C:\Program Files (x86)\Plesk\admin\plib\scripts\add-locales.php"

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.