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Smart update check in WP Toolkit cannot be started: Smart Update could not connect to the website to fetch the sitemap.

kb: technical

Symptoms

  • Smart update check in WP Toolkit on a Plesk server cannot be started and the following error message is displayed:

    PLESK_ERROR: Smart Update could not connect to the website to fetch the sitemap.

  • Plesk is installed on an AWS server with public IP address set up as external IP for NAT while it is present on a network interface.
  • Requests to webserver via public IP address from inside the server fail:

    # curl -vo /dev/null https://203.0.113.2
    * Rebuilt URL to: https://203.0.113.2/
    * Trying 203.0.113.2...
    * TCP_NODELAY set
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0* connect to 203.0.113.2 port 443 failed: Connection refused
    * Failed to connect to 203.0.113.2 port 443: Connection refused
    * Closing connection 0
    curl: (7) Failed to connect to 203.0.113.2 port 443: Connection refused

Cause

Network misconfiguration (routing, excessively strong firewall).

This is an expected behavior. However, Jira item EXTWPTOOLK-10075 was created to track customers' issues. Link this Jira ID on reuse.

Resolution

As a workaround, switch to internal resolver:

  1. Connect to a Plesk server via SSH.
  2. Open /usr/local/psa/admin/conf/panel.ini file with preferred editor and add the following content into it:

    CONFIG_TEXT: [ext-wp-toolkit]
    smartUpdatePreConfiguredDnsResolverEnabled=false

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