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MailEnable doesn't auto-reply or send notifications on Plesk for Windows

Plesk for Windows kb: technical ABT: Group A

Applicable to:

  • Plesk for Windows

Symptoms

  • MailEnable autoresponder doesn't send autoreplies.

  • This is logged to MailEnable Management > Servers > localhost > Servers and Connectors > SMTP > Logs > Activity > SMTP-Activity-date.log

    127.0.0.1 AUTH xxxxx 504 Invalid Username or Password 34 18 postmaster@localhost

    AUTH xxxxxx 504 User Account has been disabled by the mail administrator 62 18 postmaster@localhost

    SMTP-IN XXX.MAI 984 127.0.0.1 RCPT RCPT TO: john.doe@example.com 503 This mail server requires authentication when attempting to send to a non-local e-mail address. Please check your mail client settings or contact your administrator to verify that the domain or address is defined for this server.

  • This is logged to %plesk_dir%admin\logs\plesklog_debug<date>.log: after enabling debug mode for Plesk backend utilities

    Info: Create mail from='jane.doe@example.com', to='john.doe@example.net', subject='Re: Autoreply', body='Test auto-reply'
    Info: Send mail from '"" jane.doe@example.com' to '"" john.doe@example.net'
    Warning: SMTP Exception at sendMail(jane.doe@example.com, john.doe@example.net)(MessageProcessor::sendMail line 329)

Cause

The account postmaster@localhost is missing from or disabled in MailEnable Management or registry.

Resolution

Enable or recreate the missing account.

  1. Connect to the server over RDP

  2. Go to MailEnable Management > Messaging Manager > Post Offices

  3. Check if the user postmaster exists under the domain localhost
    If postmaster is absent, follow these steps to recreate it automatically:

    1. Delete localhost domain from MailEnable Management
    2. Disable and enable Use the mail server installed with Plesk and the default mail account created by Plesk in Tools & Settings > External SMTP Server

If the use of postmaster@localhost is not suitable, make sure that 127.0.0.1 is set in Host name or IP address in Tools & Settings > External SMTP Server

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