Articles in this section

Unable to renew Let's Encrypt certificate: The authorization token is not available

Plesk for Windows kb: technical ext: le ABT: Group A

Applicable to:

  • Plesk for Windows

Symptoms

  • Unable to renew the Let's Encrypt certificate for example.com with the following error message shown:

    PLESK_ERROR: Unable to renew Let's Encrypt certificate: The authorization token is not available at https://example.com/.well-known/acme-challenge/
    To resolve the issue, make sure that the token file can be downloaded via the above URL.

  • Following error can be found in %plesk_dir%\admin\logs\php_error.log:

    PLESK_ERROR: ERR [extension/letsencrypt] Domain validation failed for example.com: Invalid response from https://acme-v02.api.letsencrypt.org/acme/authz-v3/4012635280.
    Details: 
    Type: urn:ietf:params:acme:error:unauthorized 
    Status: 403 
    Detail: Invalid response from https://www.example.com/.well-known/acme-challenge/ [203.0.113.2]: "<!DOCTYPE html>\r\n<html lang=\"en\">\r\n<head>\r\n <meta charset=\"utf-8\">\r\n <meta http-equiv=\"x-ua-compatible\" content=\"ie=edge\">\r\n "

  • Upon opening https://example.com/.well-known/acme-challenge/ in the browser the following message is shown:

    CONFIG_TEXT: 404 - File or directory not found.

  • Physical path in IIS > Sites > example.com > Basic settings differs from the document root specified in the Plesk > Domains > example.com > Hosting Settings.

Cause

Site missconfiguration.

Resolution

  1. Connect to the server via RDP.
  2. Go to IIS > Sites > example.com > Basic settings and modify the physical path to the document root specified in Plesk > Domains > example.com > Hosting Settings.
Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.