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Unable to remove Wordpress instance via Applications: Permission denied

kb: bug Plesk ext: wptk

Symptoms

  • Unable to remove Wordpress instances via Domains > example.com > Applications > Remove:

    Permission Denied


    Page just reloads with no errors

  • In some cases, the process finishes with the message below, but the WordPress instance is still shown:

    {"status":"success"}

  • The following error can be observed with debug enabled in %plesk_dir%admin\logs\php_error.log:

    2019-06-19 21:45:55] ERR [extension/wp-toolkit] An error occurred when dispatching action 'removeAction': Permission denied
    [2019-06-19 21:45:55] DEBUG [extension/wp-toolkit] pm_Exception: Permission denied
    file: C:\Program Files (x86)\Parallels\Plesk\admin\plib\modules\wp-toolkit\library\Controller\Action.php

  • Attempts to remove the instance return {"status":"success"} on a blank page in a browser

Cause

This issue is reported as bug ID EXTWPTOOLK-3043 which will be fixed in future updates.

Resolution

Until the issue is resolved, the following workaround can be applied:

When the instance is shown in WP Toolkit
  1. Log into Plesk.
  2. Remove instance via WP Toolkit
When the instance is not shown in WP Toolkit
  1. Connect to the server via SSH

  2. Run the following command to find the ID of the instance:

    # plesk ext wp-toolkit --list |grep example.com |awk {'print $1"\t"$7'}
    365 http://example.com/old

  3. Remove the instance with the following command. Use the ID from step 2. as value after -instance-id:

    # plesk ext wp-toolkit --detach -instance-id 365

  4. Remove the WordPress related files of the removed instance in the file system

In case instance files are already removed from disk and the Toolkit does not detect them:

Note: The below removal of instance data process without step 3 can also be helpful if you encounter errors while trying to reattach a WP installation to the WP Toolkit after it has been detached.

  1. Scan for instances in WP Toolkit on Subscription level and identify the instances IDs from the warning: Scanning for WordPress websites was performed with errors:

    Subscription "example.com": Failed to reset cache for the instance #265: Error: This does not seem to be a WordPress installation. Pass --path=`path/to/wordpress` or run `wp core download`. Failed to reset cache for the instance #273: filemng: Failed to change directory to /var/www/vhosts/example.com/httpdocs/wordpress: No such file or directory System error 2: No such file or directory filemng: Failed to change directory to /var/www/vhosts/example.com/httpdocs/wordpress: No such file or directory System error 2: No such file or directory

  2. Manually remove instances data from WP Toolkit database:

    # cp /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3.bak

    # sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3
    sqlite> .headers on
    sqlite> delete from instanceProperties where instanceId = 265;
    sqlite> delete from instances where instances.id = 265;
    sqlite> delete from instanceProperties where instanceId = 273;
    sqlite> delete from instances where instances.id = 273;
    sqlite> .quit

  3. Remove the instances via subscription Applications tab

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