Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
- A website example.com that is hosted on a Plesk server and uses the Cloudflare nameservers (and has its primary DNS zone on the side of Cloudflare) displays the following error when opened in a browser:
CONFIG_TEXT: 522 error
Connection Timed Outor:
CONFIG_TEXT: ERR_CONNECTION_TIMED_OUT
- The website is either opening normally when resolved to a Plesk IP in the hosts file (without CloudFlare involved into processing the request) or is only showing an SSL warning that is similar to the following:
CONFIG_TEXT: Your connection is not private
This server could not prove that it is example.com; it's security certificate is not trusted
Cause
The current configuration on the end of Cloudflare for this domain blocks connections to sites with untrusted SSL. Alternatively, the domain's DNS records within the Cloudflare DNS zone are set up incorrectly (for example, one of the A records points to an IP that is not the IP of the Plesk server)
Resolution
Contact CloudFlare support for assistance with the manual configuration that has been done on the their end.
Alternatively, apply one of the following solutions:
Click on a section to expand
Attempt to fix the configuration for the domain on the side of Cloudflare by using the information in this article:
How to set up Plesk, mail autodiscover and Cloudflare to work together properly? - sections For a single domain
1. Log into the domain registrar for the affected domain
2. Change the nameservers the domain uses from the nameservers provided by Cloudflare to the nameservers that are defined within the DNS zone of the domain on the side of Plesk (usually ns1.example.com and ns2.example.com)
3. Wait for the nameservers change to take effect, after which the website should be opening fine in your browser
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