Articles in this section

Scheduled Tasks link is not shown when logging as a customer/reseller

Plesk for Windows Plesk for Linux kb: technical ABT: Group A

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Scheduled Tasks link is not being shown when logged as a customer/reseller:
  • When a user is logged as a customer/reseller -  not all domains are shown in Websites & Domains > Scheduled Tasks > Add Task > Web Space.

Cause

Scheduled tasks management option is not enabled for subscription.

Resolution

Enable Scheduler management:

For a service plan and all subscriptions under it
  1. Log into Plesk.
  2. Open Service Plans > service plan name > Permissions tab > select Scheduler management checkbox and apply changes by clicking to Update & Sync button:

    Note: Depending on number of subscriptions under this service plan, synchronization may take some time.

For a reseller
  1. Log into Plesk.
  2. Open Service Plans > Reseller Plans tab > service plan name > Permissions tab > select Scheduler management checkbox and apply changes by clicking to Update & Sync button:

    Note: Depending on number of subscriptions under this service plan, synchronization may take some time.

For one subscription from Plesk UI
  1. Create Add-on plan in Service Plans > Add an Add-on
  2. Open Permissions tab and select Scheduler management option > OK.
  3. Assign Add-on plan to subscription in Subscriptions > example.com > Change plan/add-ons:

    OR

    Open Subscriptions > example.com > Customize > Permissions > check Scheduler management box and apply changes by clicking to Update & Lock button.

    Note: In this case subscription be locked for synchronization with service plan.

For one subscription from the command-line
  1. Connect to the server via SSH or via RDP.
  2. Run the command below:

    # plesk bin subscription_settings --update example.com -manage_crontab true

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.