Applicable to:
- Plesk for Linux
Symptoms
-
When opening a website in a web browser, either Webserver Default page or the following error is shown:
PLESK_INFO: Unable to connect
-
The following error message is shown on the Home page in Plesk:
PLESK_ERROR: New configuration files for the Apache web server were not created due to the errors in configuration templates: nginx: [emerg] bind() to 203.0.113.2:443 failed (99: Cannot assign requested address) nginx: configuration file /etc/nginx/nginx.conf test failed.
-
nginx fails to start with the following error:
CONFIG_TEXT: nginx: [emerg] bind() to 203.0.113.2:443 failed (99: Cannot assign requested address)
-
Execution of
plesk repair web
command finishes with a warning:# plesk repair web
...
One or more IP addresses registered in Plesk (203.0.113.2) are missing from the server's network interfaces. Domains assigned these IP addresses (example.com) are unreachable. Assign valid IP addresses to these domains and rebuild the server configuration files........................... [WARNING] -
The IP addressfrom the warning message (203.0.113.2 in this example) is marked as broken in Plesk at Tools & Settings > IP Addresses.
-
This IP address does not exist on the system in Plesk: the following command does not list it:
# ip a | grep '203.0.113.2'
Cause
The IP address that exists in Plesk does not exist on the server.
Resolution
Apply one of the following solutions:
2. Go to Tools & Settings > IP Addresses
3. Press Repair next to the broken (usually old) IP address
-
Switch the domains from the missing IP address to the new one using the instructions from this KB article (section "Changing the IP address for all domains assigned to a specific IP address").
-
Go to Tools & Settings > IP Addresses and click Reread.
-
Select the broken IP address and click Remove.
-
Connect to the Plesk server via SSH.
-
Repair the web server configuration by executing this command:
# plesk repair web -y
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GRACIAS
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