Applicable to:
- Plesk for Linux
Symptoms
-
When logging in to Plesk or browsing pages in Plesk, one of the following error messages appears:
PLESK_INFO: Type: SWKeyExFatalError
Message: error: Cannot open file: /etc/sw/keys/infoPLESK_INFO: Type GraphQL Error
Message Internal server error
PLESK_INFO: Type: SWKeyExFatalError
Message: error: Cannot create: /etc/sw/keys/lock/repository: Permission denied -
Plesk license installation fails with:
PLESK_INFO: mkstemp failed: /etc/sw/keys/keys/keyXXXXXX: Permission denied (Error code: 2)
Cause
Permissions on the directory /etc/sw/keys
or its subdirectories are incorrect.
Resolution
-
Connect to the Plesk server via SSH.
-
Fix permissions with this command:
# /usr/sbin/usermod -a -G swkey-data psaadm && chown -R root:swkey-data /etc/sw/keys/ && chmod -R 660 /etc/sw/keys/* && chmod -R 644 /etc/sw/keys/info && find /etc/sw/keys -type d -exec chmod 2770 {} \; && chmod 4510 /etc/sw/keys/restart/* && chown -R psaadm:swkey-data /etc/sw/keys/registry.xml /etc/sw/keys/keys/*
-
Restart the Plesk services:
# service sw-engine restart && service sw-cp-server restart
-
Retrieve the Plesk license:
# plesk bin license --retrieve
If the retrieval operation fails, log in to Plesk and install your Plesk license by clicking Install Key.
Comments
0 comments
Please sign in to leave a comment.