Plesk for Windows
kb: technical
ABT: Group B
Applicable to:
- Plesk for Windows
Symptoms
- The Plesk Web Admin license is installed.
-
Microsoft SQL Server support is turned off in Tools & Settings > License Management:
- It is not possible to add MSSQL as database server in Tools & Settings > Database Servers > Add Database Servers:
- The same behavior occurs for PostgreSQL server.
-
In an attempt to add PostgreSQL server via CLI, it fails with the next error:
# plesk bin database-server --create-server localhost:5432 -type postgresql -admin admin -passwd 'password'
To use Postgresql server, you need the support for it in your license key. Please consult your Plesk sales representative.
Cause
License Limitations: PostgreSQL/MSSQL Server management is not included by default with the Plesk Web Admin license.
Resolution
It is possible to purchase Power Pack or Developer Pack, which include MS SQL/PostgreSQL support.
Note: For license questions contact Online Sales team if the license has been purchased directly in Plesk Online store. Plesk partners need to contact their sales representative.
Comments
Please sign in to leave a comment.