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Plesk backup task and other operations complete with the error: "Access denied for user 'apsc'@'localhost'" or "Error while parsing DSN"

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Plesk backup task finishes with one of the following warning messages:

    PLESK_INFO: Warning: Server "server.example.com"
    Unable to back up applications packages. Error: ODBC error #28000: [ma-3.2.6]Access denied for user 'apsc'@'localhost' (using password: YES)

    PLESK_INFO: Warning: Server "server.example.com"
    Unable to back up applications packages. Error: ODBC error #HY000: [ma-3.2.6]Error while parsing DSN

  • One of the error messages below:

    PLESK_INFO: Internal error: ODBC error #HY000: [MySQL][ODBC 3.51 Driver]
    Access denied for user 'apsc'@'localhost' (using password: YES)

    PLESK_INFO: Internal error: ODBC error #HY000: [MySQL][ODBC 3.51 Driver]
    Access denied for user 'ODBC'@'localhost' (using password: NO) 

    is shown when

    • creating a new customer or subscription in Plesk
    • installing an Applications catalog
    • accessing Application Vault at Tools & Settings
  • plesk repair db utility reports the following error:

    # plesk repair db -n
    ...
    Unable to connect to the APS database with the credentials stored in
    Plesk ............................................................. [ERROR]

Cause

Credentials for APS (apsc) database user are incorrect.

Resolution

  1. Connect to your Plesk server via SSH (Linux) / RDP (Windows Server).
  2. Repair the apsc database user credentials with the command:

    # plesk repair db -y

    Note: On Windows Server, start a command prompt as an Administrator.

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