Articles in this section

Unable to open/rename file in File Manager on Plesk server: Access denied

Plesk for Windows kb: technical ext: le ABT: Group B

Applicable to:

  • Plesk for Windows

Symptoms

  • Cannot open PHP Info page atDomains > example.com > PHP Settings > View the phpinfo() page:

    CONFIG_TEXT: Server Error
    500
    PleskUtilException
    Access denied

  • Unable to install Let's Encrypt certificate for a domain in Plesk with error below:

    PLESK_ERROR: Status: 403
    Detail: The key authorization file from the server did not match this challenge

  • Website may be inaccessible with:

    CONFIG_TEXT: 500 Internal server error

  • One of the errors below can be observed with Plesk File Manager:

    • Cannot change file permissions at Domains > example.com > File Manager:

      PLESK_ERROR: filemng failed: Unable to get the object (C:\Inetpub\vhosts\example.com\httpdocs\path\file) security info: (5) Access is denied.

    • Unable to access file or directory in File Manager with the following error:

      PLESK_ERROR: Unable to open the directory: Unable to find the directory C:\Inetpub\vhosts\example.com\httpdocs: Access denied

    • Unable to create zip archive in File Manager:

      PLESK_ERROR: Unable to create the archive: 7-Zip [32] 16.04
      %plesk_vhosts%\example.com\httpdocs\archive.zip
      Items to compress: 14161 WARNING: Access is denied
      WARNING: Cannot open 13 files at (CreateZip::onRunAsUser line 2783).

    • Unable to rename/create file(or directory)/access domain's document root in File Manager with the following error:

      PLESK_ERROR: Unable to find the directory C:\Inetpub\vhosts\example.com: Access denied

    • 'Change Permissions' option in File Manager shows all the boxes are unmarked for the subscription system user, the permissions get automatically reset

Cause

The system user does not have permissions to access subscription directories or incorrect security settings in %plesk_vhosts%example.com\.plesk\.Security file.

Resolution

  1. Connect to the server using RDP.

    Note: if direct RDP access to the server is not possible, contact server administrator for further assistance.

  2. Rename the .Security file to .Security.bak in %plesk_vhosts%example.com\.plesk directory.

  3. Open Command Prompt as Administrator and execute the following command:

    C:\> "%plesk_cli%\repair.exe" --repair-webspace-security -webspace-name example.com -all-filesystem-objects

  4. If there is %plesk_dir%\etc\DiskSecurity\permissions.xml file for customizing permissions, review the file and remove the folders of the domain in question

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.