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Plesk interface is not available: the user has not been granted the requested logon type at this computer

Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • When opening Plesk interface in a web browser, the page keeps refreshing or fails to load with the error message:

    PLESK_INFO: Unable check file existence: Logon failure: the user has not been granted the requested logon type at this computer. (Error code 1385) at Unable to logon user (WIN-2GL6V7UVGLP\Plesk Administrator)<br> at ...

    PLESK_INFO: HTTP Error 503. The service is unavailable.

  • PleskControlPanel application pool permanently goes down with the following errors in Windows Event Viewer > Windows Logs > Application:

    PLESK_INFO: Application pool PleskControlPanel has been disabled. Windows Process Activation Service (WAS) did not create a worker process to serve the application pool because the application pool identity is invalid.

    PLESK_INFO: The identity of application pool PleskControlPanel is invalid. The user name or password that is specified for the identity may be incorrect, or the user may not have batch logon rights. If the identity is not corrected, the application pool will be disabled when the application pool receives its first request. If batch logon rights are causing the problem, the identity in the IIS configuration store must be changed after rights have been granted before Windows Process Activation Service (WAS) can retry the logon. If the identity remains invalid after the first request for the application pool is processed, the application pool will be disabled. The data field contains the error number.

  • Security Audit event with ID 4625 has contents like:

    CONFIG_TEXT: An account failed to log on.Subject:
    Security ID: SYSTEM
    Account Name: SOMENAME$
    Account Domain: SOMEGRP
    Logon ID: 0x3E7Logon
    Type: 4
    Account For Which Logon Failed:
    Security ID: NULL SID
    Account Name: psaadm
    Account Domain: SOMEGRP
    Failure Information:
    Failure Reason: The user has not been granted the requested logon type at this machine.

Cause

Plesk Administrator/psaadm user is not configured correctly in the Windows system.

Resolution

  1. Connect to your Plesk server via RDP.
  2. Add Plesk Administrator user to Administrators group:

    2.1. Click on Windows Start and start typing "Computer Management" (or compmgmt.msc).

    2.2. In Computer Management, go to Local Users and Groups > Users > right-click on Plesk Administrator > Properties > switch to the Member Of tab.

    2.3. If "Plesk Administrator" does not belong to "Administrators" group, add it using Add... button and type "Administrators".


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  3. Save the changes.
  4. Right-click on psaadm user to open its Properties.
  5. On the General tab, uncheck the options Account is disabled and Account is locked out, if they are enabled.
          
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  6. Make sure that Administrators group is added to "Log on as a batch job":

    6.1. Click on Windows Start and start typing "Edit Group Policy" (or gpedit.msc).

    6.2. Go to Local Group Policy Editor > Computer Configuration > Windows Settings > Security Settings > Local Policies > User Rights Assignment > Log on as a batch job.

    6.3. Make sure that Administrators group is added, add it if it is required.

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  7. In the User Rights Assignment list, find Deny log on as a batch job and verify that "Everyone", "Plesk administrator", "Administrators" groups, psaadm user are not listed.
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