Articles in this section

Domains, Subscriptions, Customers, Resellers are missing in Plesk after license downgrade

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

    • After license downgrade (e.g. from Web Host Edition to Web Pro Edition), some domains/subscriptions are absent in Plesk in menus Domains, or Subscriptions, or Websites & Domains.

      Note: The page Add Domain or Create Your Webspace may be shown at those menus.

    • The following warnings could be found in the menu Tools & Settings > License Management:

      PLESK_WARN: Warning: Resellers management is turned off but you have several resellers(1).


      PLESK_WARN: Warning: Customers management is turned off but you have several customers(1).

The DB query shown below returns the missing subscriptions/domains in the output belonged to customers or resellers:

# plesk db "SELECT d.name AS 'Domain name',c.pname AS 'Owner Name',c.type AS 'Client Type' FROM domains d JOIN clients c ON d.cl_id=c.id WHERE d.cl_id <> 1"

+-------------+------------+-------------+
| Domain name | Owner Name | Client Type |
+-------------+------------+-------------+
| example.com | johndoe1 | client |
| example.org | johndoe2 | client |
| example.net | johndoe3 | reseller |
+-------------+------------+-------------+

Cause

Plesk does not display domains and subscriptions which belong to unsupported user types:

  • Web Pro Edition does not support Reseller management.
  • Web Admin Edition does not support Reseller and Customer management.

Resolution

via Plesk interface
  1. Log in to Plesk.

  2. Go to the menu Tools & Settings > License Management.

  3. Install the Web Host Edition (customers and resellers management) or Web Pro Edition (only customers management) license.

    Note: a trial Web Pro Edition license can be received as described here.

    If you do not have such license, follow to the next article section via Command Line Interface (CLI).

  4. Go to the menu Subscriptions.

  5. Mark all subscriptions which do not belong to the Plesk Administrator account.

  6. Click Change Subscriber button and reassign all subscription to Plesk Administrator.

  7. Remove resellers and customers if they are not required anymore.

  8. Go to the menu Tools & Settings > License Management and click Roll Back Key.

Note: In some cases, it is needed to log out and log in to Plesk again to see the results.

via Command Line Interface (CLI)
  1. Connect to the server using SSH or RDP.

  2. Get the list of subscriptions which belong to customers or resellers:

    # plesk db "SELECT d.name AS 'Domain name',c.pname AS 'Owner Name',c.type AS 'Client Type' FROM domains d JOIN clients c ON d.cl_id=c.id WHERE d.cl_id <> 1"

    +-------------+------------+-------------+
    | Domain name | Owner Name | Client Type |
    +-------------+------------+-------------+
    | example.com | johndoe1 | client |
    | example.org | johndoe2 | client |
    | example.net | johndoe3 | reseller |
    +-------------+------------+-------------+

  3. Change the ownership of required subscriptions to Plesk Administrator one by one:

    # plesk bin subscription --change-owner example.com -owner admin

    The following command can be used to change the subscription owner to Plesk Administrator for all subscription at once:

    On Linux servers:

    # for subscription in `plesk bin subscription --list`; do plesk bin subscription --change-owner $subscription -owner admin; done

    On Windows servers:

    PS foreach ($subscription in plesk bin subscription --list) {plesk bin subscription --change-owner $subscription -owner admin}

Note: In some cases, it is needed to log out and log in to Plesk again to see the results.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.