Articles in this section

Cannot update master IP address for slave DNS zone in Plesk: DNS Inconsistent zone : The NS record IN NS has no address records (A or AAAA)

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Cannot update primary IP address for secondary DNS zone or delete an NS record at Domains > example.com Hosting & DNS > DNS

PLESK_ERROR: "Error: Inconsistent zone "example.com": The NS record "example.com. IN NS ns1.example.com." has no address records (A or AAAA).; The NS record "example.com. IN NS ns2.example.com." has no address records (A or AAAA)."

Cause

No A or AAAA records exist for the NS records of the related domain and this creates a Plesk DNS records database inconsistency.

Resolution

  1. Log into Plesk

  2. Navigate to Domains > example.com > DNS Settings and click on Switch to Primary

  3. Click on Add Record and add the A or AAAA record for the NS from the error message and press OK:

    DNS.PNG

  4. Press Update to update the DNS zone

  5. Press on Switch to Secondary and then on Add Record in order to specify the IP address of the primary (master) DNS server
  6. Press OK and then Update
Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.