Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
When establishing a secure connection using Outlook the following warning is shown:
CONFIG_TEXT: The server to which you are connected uses a security certificate that can not be verified. The main destination name is not valid
-
On other mail agents different warning may be shown, for example:
CONFIG_TEXT: Mail can't verify the identity of the server "example.com". The certificate for this server is invalid. You might be connecting to a server that is pretending to be "example.com" which could put your confidential information at risk.
OR
CONFIG_TEXT: Error communicating with the IMAP server: Certificate failure for mail.example.com: unable to get local issuer certificate
-
Thunderbird may also show:
CONFIG_TEXT: Unable to obtain identification status for this site
- Mail server name specified in settings of each mail client is different from server name in the SSL/TLS certificate at Tools & Settings > SSL/TLS Certificates > Certificate for securing mail.
Cause
Wrong hostname is specified as a mail server in Mail client.
Resolution
Mail clients must use the same name for Incoming and Outgoing mail server as specified in Tools & Settings > SSL/TLS Certificates > Certificate for securing mail.
For example for Outlook under File > Account Settings > user@example.com > Change Account specify Mail server's hostname in the Incoming mail server and Outgoing mail server (SMTP) fields.
Note: the mail server hostname has to be the same as (or included) in the certificate. To know what certificate is being used by the Mail Server, on Plesk go to: Tools & Settings > SSL/TLS Certificates > Certificate for securing mail or contact your service provider.
Additional information
How to enable 587 submission port on Linux?
How to assign separate SSL certificates for different domains on a local mail server in Plesk?
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