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Cannot add MySQL/MariaDB database in Plesk Customer Panel

kb: technical Plesk Onyx for Linux ABT: Group A Plesk Onyx for Windows

Applicable to:

  • Plesk Onyx for Linux
  • Plesk Onyx for Windows

Symptoms

  • Add Database button is missing from Subscriptions > example.com > Manage in Customer Panel > Databases:

    Screenshot.png

  • The number of available database resources is set to Unlimited in Subscriptions > example.com > Account > Resources:

    Screenshot_2.png

  • Database server selection is switched off in Subscriptions > example.com > Account > Permissions:

    Screenshot_3.png

  • Cannot select database type while creating it
    OR
    Only default database servers are available for the selection.
  • MySQL/MariaDB default database server is set to None in Service Plans > Default > Hosting Parameters > Default Database Server:

    Screenshot_6.png

Cause

Default MySQL/MariaDB server is absent and/or there is no permission to select it.

Resolution

Log in to Plesk and apply one of the following:

  • Enable Database server selection directive in Service Plans > Default > Permissions > Show more available permissions and press Update & Sync:

    Screenshot_7.png

  • Switch MySQL default database server from None to localhost:3306 in Service Plans > Default > Hosting Parameters > Default Database Server and press Update & Sync:

    Screenshot_5.png

Note:  it is also applicable to cases when Amazon RDS extension is installed. If it is needed to provide customer with the ability to select Amazon server, enable "database server selection" option.

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