Plesk for Windows
Plesk for Linux
kb: technical
Ideal
Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
- A user is being logged out from Plesk periodically when navigating between pages in Plesk interface.
- Plesk redirects to the login page after a successful login attempt.
Cause
User's IP address is changed during a Plesk session. This may happen if user's IP address is dynamic or the domain/hostname, which is used to access Plesk, is behind a proxy server (for example, Cloudflare).
By default, Plesk does not allow IP address changes during a single session.
Resolution
Allow IP address changes during a single session:
Plesk interface
- Log in to Plesk (if it is not possible to log in using the hostname, use the server's IP address).
- Go to Tools & Settings > Session Idle Time (under Security section).
- Enable the option Allow IP address changes during a single session.
-
Click OK to apply the changes.
Command-line interface
- Connect to your Plesk server via SSH (Linux) / RDP (Windows Server).
-
Enable IP address changes during a single session:
Note: On Windows Server, start a command prompt as an Administrator):
# plesk bin settings --set disable_check_session_ip=true
Comments
Morning, I am having the same issues stated in this article, I have applied the fix via SSH, however this has not resolved my issue.
I have not changed IP's during the session and I have connected to our office VPN, which has a static IP and does not change, yet the issue still continues.
I have restated the server, to ensure there we no locked files etc, and this too has had no effect. I log in, click subscriptions, then get redirected to the log in page, it doesn't matter what option I select, I keep getting sent to the log in page
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