Symptoms
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Emails are not delivered to recipients
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Emails remain in mail queue at Tools & Settings > Mail Server Settings > Mail Queue tab
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The mail log at
/var/log/maillog
contains the following error regarding deferred/rejected email:450 4.7.1 Client host rejected: cannot find your hostname
hostname postfix/smtp[15775]: 3660E81C66: host mx-remote-host.com [203.0.113.3] said: 450 4.7.1 <ip-203-0-113-2.another-host.com>: Helo command rejected: Host not found (in reply to RCPT TO command)
Note: When the article is reused, please check if the information 450 4.7.1 Client host rejected: cannot find your hostname
or Helo command rejected: Host not found (in reply to RCPT TO command)
can be found in Tools & Settings > Mail Server Settings > Mail Queue by clicking on a mail stuck in mail queue, instead of checking /var/log/maillog
.
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PTR record of the sender domain's mail server is incorrect and points to another server instead of the sender's mail server:
# dig MX example.com +short
mail.example.com
# dig A mail.example.com +short
203.0.113.2
# dig -x 203.0.113.2
ip-203-0-113-2.another-host.com // should be mail.example.com
Cause
Incorrect or missing PTR record of the sender's mail server.
Resolution
Contact the server hoster or provider of the IP address in order to correct PTR record and make it pointing to the mail server hostname. For Plesk hosted on Cloud server, follow the article below:
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