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"Activate mail service on this domain" button is greyed out for a domain in Plesk

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Mail service is disabled for a domain in Plesk at Domains > example.com > Mail > Mail Settings and it is not possible to enable it through the interface, because the Activate mail service on domain button is greyed out.
  • Disabling/enabling the mail service for the domain via a command-line interface does not fix the issue:

    # plesk bin mail --off example.com

    # plesk bin mail --on example.com

Cause

Database inconsistency.

Resolution

  1. Connect to your Plesk server via SSH (Linux) / via RDP (Windows Server).
  2. Create a backup of the Plesk database:
  3. Access the Plesk database in MySQL:

    # plesk db

  4. Find ID with disabled mail service using the domain name (in the example below: domain name -example.com, ID - 167):

    MYSQL_LIN: mysql> select id from DomainServices where type='mail' and dom_id=(select id from domains where name='example.com');
    +-----+
    | id  |
    +-----+
    | 167 |
    +-----+

  5. Change mail service status using id from previous step:

    MYSQL_LIN: mysql> update DomainServices set status=0 where type='mail' and id=167;

    Query OK, 1 row affected (0.00 sec)

  6. Exist MySQL:

    MYSQL_LIN: mysql> exit

  7. Disable and enable the mail service for the subscription at Plesk > Subscriptions > example.com > Mail > Mail Settings.
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