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Subscription page in Plesk loads very slowly when XOVI SEO Toolkit extension is installed

Plesk for Linux kb: technical bug

Applicable to:

  • Plesk for Linux

Symptoms

  • When clicking on a subscription on the Subscriptions page, subscription takes a long time to open or does not get opened at all.

  • When opening XOVI SEO Toolkit extension in Plesk, it fails to open with the following error message:

    ERROR: Zend_Db_Statement_Exception: SQLSTATE[HY000]: General error: 5 database is locked (Pdo.php:61)

  • With Plesk debug mode enabled, the following error message appears in the Plesk logfile /var/log/plesk/panel.log:

    ERR [1] Zend_Db_Statement_Exception: SQLSTATE[HY000]: General error: 5 database is locked
    file: /usr/local/psa/admin/plib/vendor/plesk/zendframework/library/Zend/Db/Statement/Pdo.php
    ...

Cause

SEO Toolkit bug with ID XOVI-1639 .

Resolution

Until the bug is fixed, the following workaround can be applied:

  1. Connect to the server via SSH.

  2. Move the extension database file:

    # mv /usr/local/psa/var/modules/xovi/xovi.sqlite3 /root/

  3. Reinstall the SEO Toolkit extension:

    # plesk bin extension -u xovi && plesk bin extension -i xovi

  4. Log in to Plesk.

  5. Go to Tools & Settings > Scheduled Tasks.

  6. Disable the task analyze-logs.php of the extension Xovi.

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