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Plesk interface is not accessible on ports 8443/8880: ERR_CONNECTION_TIMED_OUT

Plesk for Windows Plesk for Linux kb: technical Ideal

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

When accessing Plesk on port 8443 or 8880 in a web-browser, the page fails to load with one of the following errors:

PLESK_INFO: This site can’t be reached
server.example.com took too long to respond.
ERR_CONNECTION_TIMED_OUT


PLESK_INFO: The connection has timed out

Cause

Plesk ports 8443/8880 are filtered by a firewall.

Resolution

 

1. Opening ports 8443/8880 in a local firewall

Plesk ports may be filtered by a local firewall installed on the system.

For Linux
  1. Connect to your Plesk server via SSH.
  2. Check the status of port 8443:

    # iptables -nL | grep 8443

  3. For some Linux distributions (CentOS 7, Debian, Ubuntu), additional package "iptables-persistent" / "iptables-services" is required to be installed before running "iptables-save":
    • on CentOS/RHEL-based distributions:

      # yum install -y iptables-services
      # systemctl enable iptables-services

    • on Debian/Ubuntu-based distributions:

      # apt install -y iptables-persistent

  4. Allow incoming connections to port 8443/8880:

    # iptables -I INPUT 1 -p tcp --dport=8443 -j ACCEPT
    # iptables -I INPUT 1 -p tcp --dport=8880 -j ACCEPT

    • for OSes with firewalld enabled, run these commands:

      # firewall-cmd --permanent --add-port=8443/tcp
      # firewall-cmd --permanent --add-port=8880/tcp
      # firewall-cmd --reload

For Windows Server

 

During Plesk installation on Windows Server, Plesk Installer automatically adds rules to Windows Firewall. To check if the rule is there, follow these steps:

  1. Connect to your Plesk server via RDP.
  2. Click Windows Start and type Windows Firewall with Advanced Security.
  3. Look for the rule names Plesk and Plesk Newsfeed in Inbound Rules.


    Windows Firewall with Advanced Security

     

    If the rules are missing, add them:

    3.1. Click New Rule... in the Inbound Rules menu.

    3.2. Select "Port" and click Next.


    2.PNG
     

    3.3. Type 8443 and click Next.


    1.PNG
     

    3.3. Select "Allow the connection" and click Next.


    3.PNG
     

    3.3. Select all profiles and click Next.


    4.PNG
     

    3.4. Name the rule "Plesk" and click Finish.


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Note: If a 3rd-party firewall/router is configured between your Plesk server and the Internet, open ports 8443/8880 there as well.

 

2. Opening ports 8443/8880 in a cloud computing service firewall

If Plesk is installed on a cloud computing service, follow the instructions for your cloud computing service to open ports 8443/8880:

 

3. Opening ports 8443/8880 on hosting/Internet service provider side

If after applying the above steps Plesk ports 8443/8880 are still shown as filtered (closed) by an online port checker (for example, ping.eu), that means that these ports are filtered on a hosting/Internet service provider side. Please, contact your hosting/Internet service provider and ask them to open these ports for you.

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Comments

2 comments
Date Votes
  • After about 7 reinstalls of Plesk i can confirm that version 18.0.76 is probably broken when doing a fresh install. My port was 100% open but the interface was still not reachable. I was able to fix this by installing version 18.0.69 and updating to the newest version. (I didnt check wich versions in between these 2 are also affected)

    2
  • Kann ich bestätigen, besagte Ports sind bei mir auch zu 100% offen aber beim Update von Version 18.0.75 auf Version 18.0.76 gibt es eine Warnung…

    INFO: Unable to connect to IP address fdba:17c8:6c94::1011 on Plesk Panel non-secure HTTP port 8880: Connection timed out
    INFO: Unable to connect to IP address fdba:17c8:6c94::1011 on Plesk Panel secure HTTPS port 8443: Connection timed out
    WARNING: Unable to connect to some Plesk ports. Please see /root/parallels/pool/PSA_18.0.76_18469/examiners/plesk_preupgrade_checker.log for details. Find the full list of the required open ports at https://support.plesk.com/hc/articles/12377821243159 
     

    0

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