Articles in this section

Unable to log in to Plesk: Unable to set up default locale: default locale does not exist or undefined

Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • When opening Plesk interface, it fails to load with the message:

    PLESK_INFO: Server Error
    500
    Type Session_Exception
    Message Unable to set up default locale: default locale does not exist or undefined.
    File Panel.php
    Line 72

  • Variable names are shown instead of human-readable output when running the command:

    C:\> plesk bin server_pref --locales-list
    cu_servpref__locales_available

Cause

Corrupted locale files.

Resolution

  1. Connect to your Plesk server via RDP.

  2. Download the latest version of locale packages:

    2.1. Open Plesk for Windows repository.

    2.2. Open the directory PLESK_WIN_XX_X_XX where XX_X_XX is the latest available Plesk version

    2.3. Open dist-windows/ directory.

    2.4. Download the locale packages plesk-locale-base-en-US.zip and plesk-l10n.zip.

  3. For safety reasons, create a copy of folders %plesk_dir%admin\application\ and %plesk_dir%admin\plib\.

  4. Open downloaded zip file plesk-locale-base-en-US.zip and:

    4.1. Copy application\ folder and paste it in %plesk_dir%admin\.

    4.2. Copy the plib\ folder and paste it in %plesk_dir%admin\.

    Note: Replace the files in destination, if asked.

  5. Open downloaded zip file plesk-l10n.zip and:

    5.1. Copy application\ folder and paste it in %plesk_dir%admin\.

    5.2. Copy the plib\ folder and paste it in %plesk_dir%admin\.

    Note: Replace the files in destination, if asked.

  6. Start a command prompt as an Administrator.

  7. Re-register locales in Plesk:

    C:\> plesk php "C:\Program Files (x86)\Plesk\admin\plib\scripts\add-locales.php"

  8. Install any missing packages using Plesk Installer:

    C:\> plesk installer update

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.