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Unable to changing an IP address for a domain in Plesk via CLI: it is already used by another account.

Plesk for Windows Plesk for Linux kb: technical ABT: Group A

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • When changing an IP address for a domain via a command-line interface, the operation fails with:

    # plesk bin subscription -u example.com -ip 203.0.113.2

    Unable to set IP address 203.0.113.2 for hosting: it is already used by another account.

  • Cannot change owner of the subscription:

    # plesk bin subscription --change-owner "example.com" -owner "JoeDoe"
    Some problems were encountered when attempting to assign some of the subscriptions to a new owner.
    Unable to continue subscription transfer: IP pool of the new owner's provider is empty. Please make sure that the provider has at least one IP address in the pool.

  • The IP address (in this example, 203.0.113.2) has the type 'dedicated' at Tools & Settings > IP Addresses.

  • The subscription belongs to a reseller or a reseller's customer.

  • The corresponding reseller does not have this IP address at Resellers > John Doe > IP Addresses.

Cause

The IP address has not been added to the reseller's IP address pool.

Resolution

  1. Log in to Plesk.

  2. Go to Resellers > John Doe > IP Addresses.


    Screenshot_2019-11-09_John_Doe_-_Plesk_Onyx_17_8_11.png

  3. Click the Add IP Address.


    Screenshot_2019-11-09_Plesk_Onyx_17_8_11_1_.png

  4. Select a required IP address from the list and click OK.

  5. Set the IP address for the domain.

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