Applicable to:
- Plesk Obsidian for Windows
Symptoms
-
Unable to change permissions from a file or directory in Plesk File Manager at Domains > domain > File Manager > example_dir > change permissions > Apply or OK. The following error is show in Plesk:
PLESK_ERROR: Error: Access is denied. (Error code 5) at GetTempFileName in C:\Windows\TEMP
at (tempFileName line 123)
at loadFromConfig(C:\Inetpub\vhosts\example.com.plesk.Security, false, true)(DiskSecurity::EntryCollection::loadFromConfig line 907)
at loadFromFile(C:\Inetpub\vhosts\example.com.plesk.Security, false)(HostingSecurity::SecurityManager::loadFromFile line 239)
at execute "C:\Program Files (x86)\Plesk\admin\bin\filemng" enterprise-pro --permissions --set-common "--file=C:\Inetpub\vhosts\example.com\httpdocs\example_dir" "--xml=C:\Program Files (x86)\Plesk\tmp{e6fa0d08-5811-11ea-8bb8-94fb7cfc58de}" --inherit-from-parent(RunTime::RunAsUser::run line 223)
(Error code 1) -
Classic ASP.NET-based website fails to open with following error:
PLESK_INFO: error '80004005'
/Index.asp, line 13OR
PLESK_INFO: Microsoft OLE DB Provider for ODBC Drivers error '80004005'
[Microsoft][ODBC Microsoft Access Driver] The Microsoft Jet database engine cannot open the file '(unknown)'. It is already opened exclusively by another user, or you need permission to view its data. -
The "Create files / write data" and "Create fodlers / append data" permissions is missing on Windows > right-click the
C:\windows\temp
directory > Security (tab) > Advanced > select Users > click Edit:
Cause
Some user groups do not have enough permissions on C:\windows\temp
directory, thus, fails to create temporary files in there from services that need it.
Resolution
Add the necessary permission on C:\windows\temp:
-
Connect to the server via RDP;
-
Right-click
C:\windows\temp\
, go to Properties > Security (tab) > Advanced > select Users > click Edit, toggle the following two permissions:- Create files / write data
- Create fodlers / append data
-
Check if there are any "Deny" rules for other groups
-
Switch them to "Allow"
-
Click OK.
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