Articles in this section

Unable to create a subscription/domain or switch the Hosting type to website hosting in Plesk: User account already exists

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

When creating a subscription/domain or switching the Hosting type to website hosting in Plesk > Domains > example.com > Hosting Settings, the following error message appears in Plesk:

PLESK_ERROR: User account jdoe already exists.

Cause

Database inconsistency.
The system user exists in the Plesk database.

Resolution

  1. Connect to the server via SSH or via RDP

  2. Create Plesk database backup

  3. Remove the Plesk system user from the Plesk database

    # plesk db "DELETE FROM sys_users WHERE login = 'jdoe'"

  4. Remove the Plesk system user from the system:

    • in Plesk for Linux:

      # deluser jdoe

      Note: On on CentOS/RHEL-based distributions, the command deluser has to be replaced with userdel.

    • in Plesk for Windows Server:

      C:\> net user jdoe /delete

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.