Articles in this section

An operation in Plesk fails: The user name or password is incorrect

Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • When creating a domain in Plesk, the operation fails with the error message:

    PLESK_ERROR: Error: filemng failed: Unable to logon user (server\johndoe): (1326) The user name or password is incorrect.
    at LogonUser(server\johndoe)(CClientProfile::logon line 126)
    at Plesk impersonation(PipeServer::ServerThread::impersonateWithoutProfile line 754)
    at execute "C:\Program Files (x86)\Plesk\admin\bin\filemng" example --ex-create-directory "--path=C:\Inetpub\vhosts\example.com\old.example.com"(RunTime::RunAsUser::run line 223)
    (Error code 1) \

  • The following error might be shown on attempts to open a website in a browser:

    PLESK_INFO: aspnetcfg failed: The user name or password is incorrect. (Error code 1326) at Unable to logon user

  • Different domain menus (e.g. ASP.NET Settings) cannot be opened:

    PLESK_INFO: GraphQL Error
    Internal error

  • In %plesk_dir%admin\logs\php_error.log, the following error is found:

    PLESK_INFO: aspnetcfg failed: Data error (cyclic redundancy check). (Error code 23) at BCryptDecrypt()

Cause

The system users accounts' credentials in the OS are out of sync with those in the Plesk database.

Resolution

  1. Connect to your server via RDP.

  2. Start a command prompt as an Administrator.

  3. Synchronize system users between Plesk and the system:

    C:\> "%plesk_cli%\repair.exe" --synchronize-impersonation-storage

  4. Repair system user accounts of all subscriptions:

    C:\> "%plesk_cli%\repair" --repair-all-webspaces-system-users

Was this article helpful?

Comments

1 comment
Date Votes
  • After upgrading from Plesk 18.0.67 Update #2 TO 18.0.74 Update 2, this error message appeared :

    • When executing a Scheduled Task created by a user (Scheduled Tasks globally created in "Tools and Settings" were properly executed)
    • When attempting to open the “Hosting Settings” panel.

    Applying the first command-line solved the problem.

    FTP Access, Cron Tasks, and IIS Application Pool permissions seems to work properly too.

    1

Please sign in to leave a comment.