Applicable to:
- Plesk for Linux
Symptoms
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All websites on Plesk server periodically are unavailable after accessing WordPress comments or working in WordPress dashboard
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Comodo or OWASP ruleset is enabled in Plesk > Tools & Settings > Web Application Firewall (Modsecurity).
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The plesk-modsecurity is enabled in Tools & Settings > IP Address Banning (Fail2Ban) > Jails:
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The following error message could be found in Tools & Settings > Web Application Firewall (Modsecurity) > ModSecurity Log File:
CONFIG_TEXT: Message: Warning. String match "get" at REQUEST_METHOD. [file "/etc/httpd/conf/modsecurity.d/rules/comodo_free/27_Apps_WPPlugin.conf"] [line "4595"] [id "222212"] [rev "2"] [severity "CRITICAL"] [tag "CWAF"] [tag "WPPlugin"]
Cause
Very restrictive ModSecurity ruleset is configured. This is causing false-positive ModSecurity rule triggering while editing or creating posts in WordPress, as a result, the IP address gets banned
Resolution
- Go to Plesk > Tools & Settings > Web Application Firewall (Modsecurity) > ModSecurity Log File.
- Find the ModSecurity rule ID mentioned in the error message
- Disable the found rule by using the steps from this article: How to disable specific ModSecurity rules in Plesk
Note: for example, the ModSecurity ID for error message presented in this article is 222212
- Log into Plesk
- Go to Tools & Settings > Web Application Firewall (ModSecurity) > Settings:
- Switch ModSecurity ruleset to Atomic Standard
- Scroll down and press the OK button to apply the changes
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