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Some Plesk actions are queued or stuck: Cannot read process exit code from file

Plesk for Windows

Applicable to:

  • Plesk for Windows

Symptoms

  • Several actions can't be completed in Plesk, like adding domains, installing extensions, updating plugins in WP Toolkit, etc.

  • %plesk_dir%admin\logs\task-manager.log has these records:

    task=223 process=223 Cannot read process exit code from file 'C:\Parallels\Plesk\var\task-manager/runtime/223/223/status.txt'
    task=223 process=223 Cannot parse process exit code: strconv.ParseInt: parsing "": invalid syntax

  • PleskTaskManager is running in Plesk Services Monitor

  • No errors in %plesk_dir%admin\logs\php_error.log with debug mode enabled.

  • Removing stuck tasks doesn't work.

Cause

Windows Server was upgraded in-place, or 3rd party services that conflict with PleskTaskManager were installed on the server.

Resolution

Migrate Plesk to a clean installation of Windows Server. As a temporary workaround, restart the Plesk Task Manager.

  1. Connect to the server over RDP
  2. Open Start, search for and open services.msc
  3. Find Plesk Task Manager Service on the list and restart it
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