Applicable to:
- Plesk for Linux
Symptoms
- The domain log viewer in Domains > example.com > Logs continues to load indefinitely and eventually a timeout error that is similar to the following may appear:
PLESK_ERROR: Maximum execution time of 600 seconds exceeded (PhpFopen.php:106)
- Node.js (also known as NodeJS) is installed on the domain and its logs are enabled
- Increasing the timeout just leads to endless loading
- The log files in
/var/log/passenger/
have sizes of 100MB or more
Cause
This issue is tied to the following known product issues:
#PPPM-13826 "Timeout when opening Logs menu in the website dashboard"
#PPPM-14003 "Passenger writes excessive logs"
The bugs above will be resolved in future versions of Plesk and can be tracked in the Change Log for Plesk Obsidian.
-
Old bug:
#PPPM-13697 "Opening Log Browser no longer results in an endless “loading” screen under specific circumstances."
Fixed in:
- Plesk Obsidian 27 September 2022 (Linux)
Resolution
As a workaround, the Node.js logs can be disabled in the Plesk GUI by editing the Plesk panel.ini configuration file and adding the following section:
CONFIG_TEXT: [ext-nodejs]
showApplicationLogs = false
Note: The Phusion Passenger log files still exist and their contents can be viewed in the /var/log/passenger/
directory of your server via command-line tools.
Comments
2 comments
Disabling the logs isn't a workaround. Sure the log viewer now loads, but it also doesn't show the logs I want to see.
I presume it's related, just had to clear out a 5GB+ passenger.log file and even with node.js uninstalled there seems to be a lot of spam going into this file (though that could be linked, but trying to learn more about it now and figure out what is going on).
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