Applicable to:
- Plesk for Linux
Symptoms
-
Various tasks in Plesk are never executed, their status in the menu Tools & Settings > Task Manager is stuck in "new".
-
The following error can be found in the log file
/var/log/plesk/task-manager.log
:ERROR Cannot fetch process properties: Cannot fetch 'run-plesk-task-93137.service' unit properties: dbus: connection closed by user
Cause
The service dbus.socket
is stuck.
Resolution
-
Connect to the server via SSH.
-
Restart services
dbus.socket
andplesk-task-manager
:# systemctl restart dbus.socket plesk-task-manager
Warning: in Debian 10 or Ubuntu 18.04, there might be the service polkit
, which also should be up and running. Restart it using the command systemctl restart polkit
in case the issue persists on these operating systems.
Only one case, reported and solved only by 1 customer (we didn't find it and solution not confirmed) - if there are files like db.sqlite3.old
and db.sqlite3-wal.old
in /var/lib/plesk/task-manager/
, move them out and wait until they are recreated.
There was a second case where this occurred in ticket 95334204. However, the db.sqlite3
files were located in the directory /var/lib/plesk/task-manager/db
. The files were moved to another directory, the dbus.socket
and plesk-task-manager
services restarted to recreate the files which resolved the issue with stuck tasks.
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