Plesk for Linux
kb: technical
Applicable to:
- Plesk for Linux
Symptoms
- Incoming emails (either local or external) do not appear in inbox.
-
Messages appear like delivered in '/var/log/maillog', but at the same time, they are not stored in mailbox directory:
/var/log/maillog.processed:Sep 11 09:30:41 pleskpostfix/smtpd[2317439]: 3FCFA63066: client=localhost.localdomain[::1], sasl_method=PLAIN, sasl_username=john.doe@example.com /var/log/maillog.processed:Sep 11 09:30:41 plesk postfix/cleanup[2320558]: 3FCFA63066: message-id=<76e4044d28cf71ddc99ade562fb76776@example.com> /var/log/maillog.processed:Sep 11 09:30:41 plesk postfix/qmgr[2282916]: 3FCFA63066: from=<john.doe@example.com>, size=570, nrcpt=1 (queue active) /var/log/maillog.processed:Sep 11 09:30:41 plesk postfix/pipe[2329805]: 3FCFA63066: to=<john.doe@example.com>, relay=plesk_virtual, delay=0.43, delays=0.39/0/0/0.04, dsn=2.0.0, status=sent (delivered via plesk_virtual service)
root@plesk # grep -ir '76e4044d28cf71ddc99ade562fb76776' /var/qmail/mailnames/example.com/john.doe root@plesk #
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Open file limits are set to default values:
# root@plesk [~]# ulimit -a | grep "open files"
open files (-n) 1024 -
Plesk hosts a lot of mailboxes:
# plesk db "select * from mail" | wc -l
3538
Cause
- Bug in Plesk with ID #PPPM-15120.
Hotfix should be coming on the next week: https://webpros.atlassian.net/browse/PPP-69492
Under investigation in https://webpros.atlassian.net/browse/PPS-18260
Resolution
Until bug is fixed, apply the following workaround to increase the limits for the open files:
- Connect to the server via SSH
-
Run the command to increase limits:
# ulimit -n 16384
-
Execute the command to regenerate configuration files for mail:
# plesk sbin mchk
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