Symptoms
- Outgoing messages from the Plesk server are not sent. Errors like the following can be found in
/var/log/maillog:
CONFIG_TEXT: Jul 9 18:34:07 [hostname] postfix/smtp[PID]: warning: relayhost configuration problem
Jul 9 18:34:07 [hostname] postfix/smtp[PID]: [MSGID1]: to=<user@example.com>, relay=none, delay=984, delays=984/0.04/0/0, dsn=4.3.5, status=deferred (mail for 203.0.113.10 loops back to myself)
Jul 9 18:34:07 [hostname] postfix/smtp[PID]: warning: relayhost configuration problem
Jul 9 18:34:07 [hostname] postfix/smtp[PID]: [MSGID2]: to=<user@example.com>, relay=none, delay=1134, delays=1134/0.04/0/0, dsn=4.3.5, status=deferred (mail for 203.0.113.10 loops back to myself)
Cause
The Smarthost feature is enabled in Plesk and the server's IP address 203.0.113.10 is set as the Smarthost IP address. This misconfiguration is causing Postfix to try to relay the outgoing emails to itself, resulting in the mail loop.
Resolution
- Log into Plesk.
- Go to Tools & Settings > Mail Server Settings > Smarthost.
- Uncheck the Send users' mail via a smarthost option.
- Click OK to save the changes.
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