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A backup cannot be created on a Plesk server: Unable to back up applications packages. Error: ODBC error #HY000: [ma-3.1.20]Can't connect to server on 'localhost' (115)

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • A backup creation fails with the following error in Plesk > Tools & Settings > Backup Manager:

    Error: ODBC error #HY000: [ma-3.1.20]Can't connect to server on 'localhost' (115)

  • plesk repair db does not report any issues with the database.

  • Plesk database apsc table is consistent:

    # plesk db "show tables from apsc;"
    +------------------------------------+
    | Tables_in_apsc |
    +------------------------------------+
    | aps_application |
    | aps_application_backup |
    | aps_log_param |
    | aps_package |
    | aps_package_configuration |
    | aps_package_global_setting |
    | aps_package_resource_configuration |
    | aps_package_resource_setting |
    | aps_package_series |
    | aps_package_service |
    | aps_registry_object |
    | aps_registry_object_setting |
    | aps_registry_object_tag |
    | aps_resource |
    | aps_resource_adjacency_list |
    | aps_resource_backup |
    | aps_resource_log |
    | aps_resource_requirement |
    | aps_resource_requirement_backup |
    | aps_resource_usage_counter |
    | aps_resource_usage_report |
    | aps_settings_sequenses |
    | meta_info |
    +------------------------------------+
    23 rows in set (0,001 sec)

  • The /etc/hosts has an incorrect IP address for localhost:

    # less /etc/hosts
    125.0.0.1 localhost.localdomain localhost

Cause

An incorrect IP address for localhost causes the connection to the database to fail. Typically, 127.0.0.1 IP address belongs to localhost.

Resolution

  1. Log into the server via SSH.
  2. Edit /etc/hosts with vi editor (or any other of your choice) to change the IP address to 127.0.0.1.
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