Articles in this section

Roundcube autoresponder emails not delivered to Gmail accounts

kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • An autoresponder is configured in Roundcube via Settings > Filters.
  • Roundcube automatic replies are sent with empty sender.
  • The auto reply is not received by Gmail accounts.
  • The following entry is found in /var/log/maillog:

Your email has been blocked because the sender is unauthenticated. 550-5.7.26 Gmail requires all senders to authenticate with either SPF or DKIM. 550-5.7.26 550-5.7.26 Authentication results: 550-5.7.26 DKIM = did not pass 550-5.7.26 SPF [] with ip: [203.0.113.2 ] = did not pass 550-5.7.26 550-5.7.26 For instructions on setting up authentication, go to 550 5.7.26 https://support.google.com/mail/answer/81126#authentication a640c23a62f3a-a8988f40789si300814366b.20 - gsmtp (in reply to end of DATA command))

  • The SPF, DKIM and DMARC records are correct.
  • The Roundcube autoreply is received by users on other mail providers.
  • The message is received on Gmail when the Auto-Reply option in Plesk is used instead.

Cause

The auto reply messages via Roundcube use the Sieve extension "Vacation" which sends auto-replies via sendmail from popuser with <> as sender to prevent loops.

Jan 1 00:00:00 server postfix/qmgr[1111111]: 1A234B5C6: from=<>, size=111, nrcpt=1 (queue active)

Therefore, the sender cannot be authenticated and Gmail rejects message because their system requires all messages to be authenticated.

Resolution

Click on a section to expand

Workaround 1

Use the Auto-Reply option in Plesk under Mail Settings for each email account. The from field will contain the sender:

Jan 1 00:00:00 server plesk-sendmail[1234567]: A123456: from=plesktest@example.com to=testmailplesk@gmail.com

Workaround 2

Modify the Sieve configuration as follows:

1. Connect to the server via SSH.
2. Create a Sieve configuration file in the Dovecot configuration folder:

# touch /etc/dovecot/conf.d/90-sieve.conf

3. Add the following directives to the newly created /etc/dovecot/conf.d/90-sieve.conf file using new Dovecot 2.4 syntax:

sieve_extensions {
vacation-seconds = yes
}
sieve_vacation_send_from_recipient = yes

4. Restart the Dovecot service:

# systemctl restart dovecot

Note: The Fix incorrectly set sender for outgoing mail option does not resolve the issue with Roundcube filters autoreply.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.