Articles in this section

Email stuck in queue after removing Plesk Email Security: connect to transport private/smtp-amavis: Connection refused

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • After removing Plesk Email Security, some deferred mail can't be sent, logging these errors to /var/log/maillog

    postfix/qmgr[2032]: warning: connect to transport private/smtp-amavis: Connection refused
    postfix/error[9094]: 92B61A0127: to=<jdoe@example.com>, relay=none, delay=213065, delays=213065/0/0/0.19, dsn=4.3.0, status=deferred (mail transport unavailable)

  • Amavis is not installed

    # dpkg --list | egrep -i amavis
    (Empty Output)

  • There's no Amavis configuration in Postfix

    Note: If there are Amavis leftovers, follow this guide to remove them: Unable to send email in Plesk: mail transport unavailable

    # egrep -Ri amavis /etc/postfix/
    (Empty Output)

Cause

Email messages that were managed by Amavis are still in the mail queue, but can't be sent because Amavis is no longer installed.

Resolution

  1. Connect to the server via SSH

  2. Run the following command:

    # plesk sbin mchk --without-spam

  3. Restart Postfix:

    # systemctl restart postfix

  4. Resend the stuck email messages:

    Note: Deferred mail can take some time to send. Monitor the progress in Tools & Settings > Mail Server Settings > Mail Queue

    # postsuper -r ALL

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.