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Restoring incorrect locale during the migration process

Plesk for Linux kb: technical ext: migrator

Symptoms

  • Following a migration, the locale is set to null for additional users:

    # plesk db "SELECT email, contactName, login, locale FROM smb_users;"
    +-----------------------+----------------+----------+--------+
    | email | contactName | login | locale |
    +-----------------------+----------------+----------+--------+
    | admin@example.com | Administrator | admin | en-US |
    | john.doe@example.com | John Doe | john.doe | NULL |
    +-----------------------+----------------+----------+--------+

Cause

Plesk Migrator extension bug #PMT-5270.

Resolution

Workaround:

  1. Connect to the target server via SSH.

  2. Create Plesk database backup.

  3. Access Plesk database.

  4. Run the following to list users with "NULL" locale:

    # plesk db "SELECT email, contactName, login, locale FROM smb_users WHERE locale IS NULL"
    +-----------------------+----------------+----------+--------+
    | email | contactName | login | locale |
    +-----------------------+----------------+----------+--------+
    | john.doe@example.com | John Doe | john.doe | NULL |
    +-----------------------+----------------+----------+--------+

  5. To change the locale to "en-US" for all users where the locale is "NULL":

    # plesk db "UPDATE smb_users SET locale='en-US' WHERE locale IS NULL"

Note: All available locales can be displayed with the following command:

# plesk bin server_pref --locales-list

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