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The greylisting server-wide whitelist is not working: Personal grey listing configuration allowed

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • Plesk Obsidian running on a Linux-based operating system
  • An email is getting deferred due to greylisting, for example:

    # root@server:~# cat /var/log/maillog | grep 896EF17404A
    Mar 8 11:51:10 server postfix/smtpd[157532]: 896EF17404A: client=a77-777.smtp-out.amazonses.com[203.0.113.2]
    Mar 8 11:51:10 server psa-pc-remote[3084062]: 896EF17404A: from=<0100018e1dac3ac4-9401905a-0d4c-435c-8f22-f72bd196bf61-000000@email.dropbox.com> to=<info@example.com>
    Mar 8 11:51:10 server psa-pc-remote[3084062]: 896EF17404A: grey: stderr: DEFER
    Mar 8 11:51:10 server postfix/smtpd[157532]: 896EF17404A: milter-reject: DATA from client=a77-777.smtp-out.amazonses.com[203.0.113.2]: 451 4.7.1 Service unavailable - try again later; from=<0100018e1dac3ac4-9401905a-0d4c-435c-8f22-f72bd196bf61-000000@email.dropbox.com> to=<info@example.com> proto=ESMTP helo=<a77-777.smtp-out.amazonses.com>

  • Greylisting is enabled server-wide within Plesk, the incoming sender address is whitelisted within the serverwide greylist, but the Personal grey listing configuration setting is set to allowed:

    # root@server:~# /usr/local/psa/bin/grey_listing --info-server
    Grey listing configuration.
    ...
    Personal grey listing
    configuration allowed
    Server-wide black list:
    Server-wide white list:
    White domains patterns list:
    *@email.dropbox.com

  • Greylisting for the domain example.com is enabled:

    # root@server:~# plesk bin grey_listing --info-domain example.com
    Grey listing for domain is enabled

  • The personal greylisting whitelist for the mailbox info@example.com does not contain the incoming sender address:

    # root@server:~# plesk bin grey_listing --info-mailname info@example.com
    Grey listing configuration for info@example.com. 
    User's black list:
    User's white list:
    SUCCESS: Gathering information for 'info@example.com' complete.

Cause

When the personal grey listing configuration is set to allowed, the mailbox greylisting whitelist overrides the server greylisting whitelist, due to which the mailbox must have the sender address added to its own greylisting whitelist in order to be whitelisted.

Resolution

Note: To prohibit applying mail user level configurations of greylisting on the server, you can execute the following command:

# plesk bin grey_listing --update-server -status on -personal-conf false

To resolve the experienced issue without changing the the current configuration settings, you must add *@email.dropbox.com to the whitelist of the mailbox info@example.com by following these steps:

1. Log into your server via SSH as the root user

2. Add *@email.dropbox.com to the whitelist of the mailbox info@example.com by executing the following command:

# plesk bin grey_listing --update-mailname info@example.com -whitelist add:*@email.dropbox.com

 3. This will make the whitelist configuration for this mailbox the following:

# root@web1:~# plesk bin grey_listing --info-mailname info@example.com
Grey listing configuration for info@examplecom.

User's black list:

User's white list:
*@email.dropbox.com

SUCCESS: Gathering information for 'info@example.com' complete.

Now that *@email.dropbox.com is added to the personal greylisting whitelist for this mailbox, the emails from the sender address should be able to reach that mailbox without issues.

Additional information

grey_listing: Greylisting | Plesk Obsidian documentation

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