Symptoms
-
Plesk Email Security extension is installed on the server
- In an attempt to access Plesk Email Security the following error is shown:
SQLSTATE[HY000] [1045] Access denied for user 'user1'@'localhost' (using password: YES)
-
Mail stuck in the queue with below message in
/var/log/maillog:Feb 5 12:07:05 admin amavis[211238]: (211238-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=emailsecurity;host=localhost;port=3306': Access denied for user 'user1'@'localhost' (using password: YES)
Feb 5 12:07:05 admin amavis[211238]: (211238-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 123) line 253.
Feb 5 12:07:05 admin amavis[211238]: (211238-01) (!)Requesting process rundown after fatal error
(delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Cause
Plesk Email Security was not correctly installed.
Resolution
-
Remove Plesk Email Security extension under Home > Extensions
-
Resubmit message to the queue:
# postsuper -r ALL
-
Afterward, install Plesk Email Security back if it is required.
Comments
Please sign in to leave a comment.