Applicable to:
- Plesk for Windows
Symptoms
-
The auto reply mailbox domain has its DMARC policy set to reject
"v=DMARC1; p=reject; pct=100"
-
Auto replies sent by the local mail server are sent to spam or not delivered at all, with the following error
550-5.7.26 Unauthenticated email from example.com is not accepted due to 550-5.7.26 domain's DMARC policy.
-
Auto replies sent by external mail server are not delivered, with the following logged to
plesk_debugYYYYMMDD.log
Warning: SMTP Exception
at Unable to call send()(SMTPClientSessionTransport::send line 114)
at Unable to call send()(PocoMailMessage::Impl::send line 323)
at sendMail(jdoe@example.com, jdoe2@example.com)(MessageProcessor::sendMail line 335) -
External SMTP server users can't send email
# curl smtp://email-smtp.ap-south-1.amazonaws.com:587 -v --mail-from "XXXXXXXXXXXXX" --mail-rcpt "jdoe@example.com" --ssl -u XXXXXXXXXXXXX:*** -T input.txt -k --anyauth
...
curl: (55) MAIL failed: 501
Cause
Plesk product issue PPPM-12688.
Resolution
Warning: Using a mail client is the only solution that works 100% of the time.
There are 3 possible workarounds for this issue.
-
Configure auto replies in a mail client: How to set up auto replies in Outlook.
-
Configure auto replies directly in MailEnable: How to configure auto responder in MailEnable
-
Edit the domain's DMARC record, changing its policy to ignore DMARC errors:
"v=DMARC1; p=none"
Note: This method won't help with mail relay cases; auto replies may still be sent to spam.
Comments
0 comments
Please sign in to leave a comment.