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Auto replies are not received by external mail servers

kb: bug Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • The auto reply mailbox domain has its DMARC policy set to reject

    "v=DMARC1; p=reject; pct=100"

  • Auto replies sent by the local mail server are sent to spam or not delivered at all, with the following error

    550-5.7.26 Unauthenticated email from example.com is not accepted due to 550-5.7.26 domain's DMARC policy.

  • Auto replies sent by external mail server are not delivered, with the following logged to plesk_debugYYYYMMDD.log

    Warning: SMTP Exception
    at Unable to call send()(SMTPClientSessionTransport::send line 114)
    at Unable to call send()(PocoMailMessage::Impl::send line 323)
    at sendMail(jdoe@example.com, jdoe2@example.com)(MessageProcessor::sendMail line 335)

  • External SMTP server users can't send email

    # curl smtp://email-smtp.ap-south-1.amazonaws.com:587 -v --mail-from "XXXXXXXXXXXXX" --mail-rcpt "jdoe@example.com" --ssl -u XXXXXXXXXXXXX:*** -T input.txt -k --anyauth
    ...
    curl: (55) MAIL failed: 501

Cause

This was caused by a Plesk product issue, PPPM-12688.

Resolution

Starting from version 18.0.69, the Plesk implementation has been removed in favor of the native solutions from the mail server installed. As such, auto-replies should now be configured as follows: 

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