Applicable to:
- Plesk for Windows
Symptoms
-
On a Windows server running Plesk Obsidian, emails cannot be sent and the following is displayed in Plesk > Tools & Settings > Mail Server Settings:
You cannot send emails from Plesk because outbound connections on TCP ports 25 and 587 are blocked. Check the firewall settings or contact your hosting provider. If you are sure that the ports are already open, Plesk can recheck them.
Start the recheck -
Querying the ports with telnet towards a functioning mail server from the Windows Plesk server itself results in the following output:
C:\Users\Administrator>telnet smtp.gmail.com 25
Connecting To smtp.gmail.com...Could not open connection to the host, on port 25: Connect failedC:\Users\Administrator>telnet smtp.gmail.com 587
Connecting To smtp.gmail.com...Could not open connection to the host, on port 587: Connect failed -
There are no firewall rules which might block these ports on the server itself
Cause
A firewall that resides on a level above the server itself is rejecting outbound connections towards 25 and 587 TCP ports. Many server providers are blocking outbound connections via these ports by default, however not all.
Resolution
Contact your server provider in order to check if it is possible for them to remove the block for outgoing TCP ports 25 and 587 for your server's IP address.
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