Applicable to:
- Plesk for Linux
Symptoms
-
SSO connection to Plesk though WHMCS fails. Login to Plesk from WHMCS redirects to Plesk login page back instead of logging in.
-
WHMCS is behind Cloudflare,
Cause
User's IP address is changed during a Plesk session. This may happen if user's IP address is dynamic or the domain/hostname which is used as a URL for Plesk is behind Cloudflare.
By default, Plesk does not allow IP address changes during a single session.
Resolution
Allow IP address changes during a single session:
-
Log in to Plesk (use the server IP address if it is not possible to log in using the hostname).
-
Go to Tools & Settings > Session Idle Time and enable the option Allow IP address changes during a single session.
-
Click OK to apply the changes.
-
Connect to the Plesk server via SSH (Linux) / RDP (Windows Server).
-
Run the following command to enable IP address changes during a single session (on Windows Server, start a command prompt as an Administrator):
# plesk bin settings --set disable_check_session_ip=true
Comments
0 comments
Please sign in to leave a comment.