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SMTP Mail Delivery System reports aren't sent from within the server

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

Delivery reports, like bounced email notifications, fail to send when emailing a non-existent email address, with these errors in /var/log/maillog

to=jdoe@example.com, relay=none, delay=0.19, delays=0.19/0/0.01/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=example.com type=AAAA: Host not found)
DKIM Feed: No signature
DMARC: smtpdomain= maildomain=plesk.example.com mailfrom=MAILER-DAEMON@plesk.example.com stamp=1701353376 ip=unknown adkim=relaxed aspf=relaxed p=REJECT sp=UNSPECIFIED pct=100 align_dkim=fail align_spf=fail spfres=unknown dkimres=unknown dmarccheck=DMARC_POLICY_REJECT dmarcstatus=STOP
postfix-local[29983]: message discarded by a mail handler

Cause

DMARC checks are enabled, and the bounce back email is sent from a MAILER-DAEMON that is not associated with a domain, so DMARC fails. When DMARC checks fail, the email is discarded, so no bounce back message is generated.

Resolution

Configure the mail server to reject emails that fail the DMARC check.

  1. Connect to the server via SSH

  2. Enable rejection of DMARC failed messages

    # plesk bin settings -s mail_dmarc_reject_at_smtp=true && plesk repair mail -y

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