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Nginx and Apache intermittently show error 499 in the access log in Plesk when Cloudflare is being used

Plesk for Linux kb: technical

Symptoms

  • The following error appears in Domains > example.com >Logs:

PLESK_ERROR: Error 499 HTTP/1.1

  • The following can be found in /var/www/vhosts/example.com/logs/proxy_access_log:

CONFIG_TEXT: "GET / HTTP/1.1" 499 0 "-" "Mozilla/5.0 (compatible; Cloudflare-Traffic-Manager/1.0; +https://www.cloudflare.com/traffic-manager/; pool-id: 0x0x0x0x0x0x0x0x0)"

  • The website is working under Cloudflare protection.

Cause

Cloudflare Load Balancer requests the website data in the scope of a TCP session. If this session was not finished in 5 seconds, it sends the FIN packet initiating the finishing of this session. Meanwhile, the webserver is still processing the request, but the TCP session is finished by the client (Cloudflare). Therefore, the web server throws error 499 in the logs. By default, timeout is set to 5 seconds in the Cloudflare Load Balancer settings.

Resolution

Increase the timeout to an appropriate value on the Cloudflare side.
Contact Cloudflare support or its community for further assistance.

 

For more information, check Cloudflare documentation:
https://developers.cloudflare.com/load-balancing/get-started/quickstart/#create-a-monitor

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